FoxTrot Search Forum
FoxTrot Search for macOS Forum

Home » Public Forums » FoxTrot Search User Forum » Full Disk Access (Foxtrot keeps asking for Full Disk Access)
Full Disk Access [message #1213] Thu, 27 May 2021 03:57 Go to next message
Peter Morris
Messages: 12
Registered: July 2018
Location: Trinidad West Indies
Junior Member
Since upgrading to Mac OS 11.4 Big Sur last night, Foxtrot v 7.04 build 2612 keeps throwing up warning messages that it needs Full Disk Access.
I am using a Mac PowerBook Pro 16" 2019.

I have granted Foxtrot Full Disk Access in the Security & Privacy System Preferences but I still keep getting the same messages and certain files (especially Mail messages) are not being indexed.
I tried re-starting and I tried disabling and re-enabling Full Disk Access, but the problem continues.

Any suggestions ?

Peter
Re: Full Disk Access [message #1214 is a reply to message #1213] Thu, 27 May 2021 11:13 Go to previous messageGo to next message
FoxTrot Engineering
Messages: 347
Registered: April 2020
Senior Member
Some locations are completely inaccessible to applications, for security reasons, even when granting them "full disk access" (e.g. some folders in the hidden folder /private/var). FoxTrot is not supposed to report an error when trying to index these folders, but it seems that something has changed in macOS 11.4. We will fix this in the next release.
The error message you get should indicate the list of folders that can't be accessed, and if you granted "full disk access", this list should not include your Mail folder nor other legitimate locations.
Thanks for the report


Jérôme - FoxTrot Engineering
Re: Full Disk Access [message #1237 is a reply to message #1214] Fri, 18 June 2021 11:04 Go to previous message
FoxTrot Engineering
Messages: 347
Registered: April 2020
Senior Member
The "Full Disk Access" problem also occurs on macOS 11.4 for other folders (Mail etc) when a scheduled update is enabled for at least one index.
One possible workaround is to disable scheduled updates for all your indices, then rebooting your Mac (or logging out your macOS account).
A better workaround:
- open System Preferences / Security & Privacy / Privacy / Full Disk Access
- unlock the padlock, and leave this window visible
- in the Finder, locate the FoxTrot application
- right-click it and choose "Show Package Contents"
- navigate to Contents / MacOS
- drag FTStarter to the list of processes to grant Full Disk Access
- reboot your Mac (or logout your macOS account)


Jérôme - FoxTrot Engineering
Previous Topic: Missing Space within Clause
Next Topic: unable to index Outlook Main Profile folder
Goto Forum:
  


Current Time: Mon Nov 28 13:34:34 CET 2022