FoxTrot Search Forum
FoxTrot Search for macOS Forum

Home » Public Forums » FoxTrot Search User Forum » Foxtrot is not indexing RTFD files
Foxtrot is not indexing RTFD files [message #1295] Sat, 13 November 2021 16:20 Go to next message
Des Bw
Messages: 26
Registered: June 2017
Junior Member
RTFD is supposed to be native to the mac. They are rtf files with images. But, I just realized that Foxtrot is not indexing them. Embarrassed

I reset the file type with : defaults delete com.ctmdev.FoxTrot Aliases , and rebuild my index with no avail.

I also tried to run: defaults write com.ctmdev.foxtrot Aliases -array-add "{type='rtfd'; as='rtf';}", as well as defaults write com.ctmdev.foxtrot Aliases -array-add "{type='rtfd'; as='txt';}"

None of them are working. This is strange. What should I do to make FT to index them?

[Updated on: Sat, 13 November 2021 16:33]

Report message to a moderator

Re: Foxtrot is not indexing RTFD files [message #1296 is a reply to message #1295] Sat, 13 November 2021 17:00 Go to previous messageGo to next message
CTM info
Messages: 172
Registered: September 2009
Senior Member
Hello,

Not sure whether this helps, but what version of macOS are you running ? I just read that 11.6 included an update to its built-in rtf mdimporter, and this might be a factor. I am running 11.6 and have rtfd documents indexed indeed.

regards,

jean michel/ctm qa
Re: Foxtrot is not indexing RTFD files [message #1297 is a reply to message #1296] Sun, 14 November 2021 08:25 Go to previous messageGo to next message
Des Bw
Messages: 26
Registered: June 2017
Junior Member
I am running 10.13.

I have never noted that these files were not indexed until yesterday.

rtf files are correctly indexed; but not the RTFD ones.

Is there anything I can do that could help me to index them?

[Updated on: Sun, 14 November 2021 08:26]

Report message to a moderator

Re: Foxtrot is not indexing RTFD files [message #1301 is a reply to message #1295] Mon, 15 November 2021 10:39 Go to previous message
FoxTrot Engineering
Messages: 385
Registered: April 2020
Senior Member
Not sure why this does not work for you.

Tweaking the com.ctmdev.foxtrot Aliases preference won't work, as .rtfd files are in fact folders containing a .rtf file and embedded images, so trying to parse a folder as a file will have an unexpected behavior.

Did you rebuild your index after resetting this preferences? Also, please note that beginning with FoxTrot 7.1, these command line preferences should be set to the com.ctmdev.FoxTrotShared domain, instead of com.ctmdev.FoxTrot or com.ctmdev.FoxTrotPro depending if the preference is specific or not to FoxTrot Professional or Personal. Preferences previously set for the legacy domains should have been automatically transferred to com.ctmdev.FoxTrotShared, so to reset the Alias preference, type:
defaults delete com.ctmdev.FoxTrotShared Aliases
Also delete the preference in the other domains as well, just in case:
defaults delete com.ctmdev.FoxTrot Aliases
defaults delete com.ctmdev.FoxTrotPro Aliases
Is "word processor" enabled, in the "index contents of files" list of the "indexed data" tab?
Which items are enabled in the "including" popup menu? Note that if "files inside packages" AND "also include files inside spotlight-supported packages", then the .rtf file (as well as the image files) embedded inside the .rtfd package should be indexed in addition to the .rtfd package itself.


Jérôme - FoxTrot Engineering
Previous Topic: Black Friday/Cyber Monday discounts?
Next Topic: How to Contact Purchasing
Goto Forum:
  


Current Time: Fri May 31 00:52:58 GMT+2 2024