FoxTrot Search Forum
FoxTrot Search for macOS Forum

Home » Public Forums » FoxTrot Search User Forum » Very unsatisfied FoxTrot Search Server + Professional Search: client not connecting to the server
Very unsatisfied FoxTrot Search Server + Professional Search: client not connecting to the server [message #772] Mon, 11 June 2018 23:17 Go to next message
Dirk Kannapinn
Messages: 2
Registered: June 2018
Junior Member
Today we bought a license for FoxTrot Search Server and FoxTrot
Professional search for 10 users. I installed the server on a for this
purpose designed Mac mini with i7 with 16GB RAM and a Fuision drive.
Indexing took about approx. 6 hours and finished correctly. When I start
Professional search on the same machine it works. But if I install
Professional search on a different machine (iMac, High Sierra, 10.13.5) and
try to connect it won't.

In the servers list on the left there appear the Bonjour name of the server
where FoxTrot Server is installed. But I'm unable to check the server.
Nothing happens. If a add this server with its DNS name (name.domain.local)
it appears a message that the self signed certificate isn't trustful. If I
check to make it trustful this message appears again and again and again
and again. But it won't show me the main index of the server.

All configurations (Bonjour, IP addresse, accounts and passwords) are
correct.

In the log of the FoxTrot Search Server I found these lines:

2018/06/11, 23:04:40 +0200: client thread 0x00007f9597459c00 stopped
class=SSL , what=1, when=2, err=1,
name=error:00000001:lib(0):func(0):reason(1) (ssl lib=20, function=148,
reason=1048, string=error:14094418:SSL routines:ssl3_read_bytes:tlsv1 alert
unknown ca)
class=SSer, what=100, when=1, err=0, name=
2018/06/11, 23:04:50 +0200: ...client talking from host
::ffff:192.168.xx.xx port 50783...
2018/06/11, 23:04:50 +0200: ...client connected
2018/06/11, 23:04:50 +0200: waiting connection on port 50000...
2018/06/11, 23:04:50 +0200: client thread 0x00007f9597459c00 started
2018/06/11, 23:04:50 +0200: client thread 0x00007f9597459c00 stopped
2018/06/11, 23:04:50 +0200: ### HIERARCHICAL EXCEPTION CAUGHT
(Starter::LogExceptionPipe) ###
class=SSL , what=1, when=2, err=1,
name=error:00000001:lib(0):func(0):reason(1) (ssl lib=20, function=148,
reason=1048, string=error:14094418:SSL routines:ssl3_read_bytes:tlsv1 alert
unknown ca)
class=SSer, what=100, when=1, err=0, name=
2018/06/11, 23:05:12 +0200: ...client talking from host
::ffff:192.168.xx.xx port 50785...
2018/06/11, 23:05:12 +0200: ...client connected
2018/06/11, 23:05:12 +0200: waiting connection on port 50000...
2018/06/11, 23:05:12 +0200: client thread 0x00007f9597460e60 started
2018/06/11, 23:05:12 +0200: ### HIERARCHICAL EXCEPTION CAUGHT
(Starter::LogExceptionPipe) ###
2018/06/11, 23:05:12 +0200: client thread 0x00007f9597460e60 stopped
class=SSL , what=1, when=2, err=1,
name=error:00000001:lib(0):func(0):reason(1) (ssl lib=20, function=148,
reason=1048, string=error:14094418:SSL routines:ssl3_read_bytes:tlsv1 alert
unknown ca)
class=SSer, what=100, when=1, err=0, name=


It seems to be a major bug with the server. When do you fix this error? *We
paid today 500 Euros and are not able to work with the software!*
Re: Very unsatisfied FoxTrot Search Server + Professional Search: client not connecting to the server [message #773 is a reply to message #772] Tue, 12 June 2018 02:38 Go to previous messageGo to next message
CTM Development
Messages: 57
Registered: April 2014
Member
Sir,,

Thank you for your report. This is definitely a bug which we acknowledge, and it is actively being worked on.

Noting that we do offer a 30 day evaluation period in advance of purchase to avoid inconveniences, if we are unable to provide a fix within 10 working days then we will obviously refund you,

Would you be so kind as to continue this discussion in private email stating your intentions please.

Thank you and kind regards,

jean michel / ctm qa


> On Jun 11, 2018, at 23:17, Dirk Kannapinn wrote:
>
> Today we bought a license for FoxTrot Search Server and FoxTrot Professional search for 10 users. I installed the server on a for this purpose designed Mac mini with i7 with 16GB RAM and a Fuision drive. Indexing took about approx. 6 hours and finished correctly. When I start Professional search on the same machine it works. But if I install Professional search on a different machine (iMac, High Sierra, 10.13.5) and try to connect it won't.
>
> In the servers list on the left there appear the Bonjour name of the server where FoxTrot Server is installed. But I'm unable to check the server. Nothing happens. If a add this server with its DNS name (name.domain.local) it appears a message that the self signed certificate isn't trustful. If I check to make it trustful this message appears again and again and again and again. But it won't show me the main index of the server.
>
> All configurations (Bonjour, IP addresse, accounts and passwords) are correct.
>
> In the log of the FoxTrot Search Server I found these lines:
>
> 2018/06/11, 23:04:40 +0200: client thread 0x00007f9597459c00 stopped
> class=SSL , what=1, when=2, err=1, name=error:00000001:lib(0):func(0):reason(1) (ssl lib=20, function=148, reason=1048, string=error:14094418:SSL routines:ssl3_read_bytes:tlsv1 alert unknown ca)
> class=SSer, what=100, when=1, err=0, name=
> 2018/06/11, 23:04:50 +0200: ...client talking from host ::ffff:192.168.xx.xx port 50783...
> 2018/06/11, 23:04:50 +0200: ...client connected
> 2018/06/11, 23:04:50 +0200: waiting connection on port 50000...
> 2018/06/11, 23:04:50 +0200: client thread 0x00007f9597459c00 started
> 2018/06/11, 23:04:50 +0200: client thread 0x00007f9597459c00 stopped
> 2018/06/11, 23:04:50 +0200: ### HIERARCHICAL EXCEPTION CAUGHT (Starter::LogExceptionPipe) ###
> class=SSL , what=1, when=2, err=1, name=error:00000001:lib(0):func(0):reason(1) (ssl lib=20, function=148, reason=1048, string=error:14094418:SSL routines:ssl3_read_bytes:tlsv1 alert unknown ca)
> class=SSer, what=100, when=1, err=0, name=
> 2018/06/11, 23:05:12 +0200: ...client talking from host ::ffff:192.168.xx.xx port 50785...
> 2018/06/11, 23:05:12 +0200: ...client connected
> 2018/06/11, 23:05:12 +0200: waiting connection on port 50000...
> 2018/06/11, 23:05:12 +0200: client thread 0x00007f9597460e60 started
> 2018/06/11, 23:05:12 +0200: ### HIERARCHICAL EXCEPTION CAUGHT (Starter::LogExceptionPipe) ###
> 2018/06/11, 23:05:12 +0200: client thread 0x00007f9597460e60 stopped
> class=SSL , what=1, when=2, err=1, name=error:00000001:lib(0):func(0):reason(1) (ssl lib=20, function=148, reason=1048, string=error:14094418:SSL routines:ssl3_read_bytes:tlsv1 alert unknown ca)
> class=SSer, what=100, when=1, err=0, name=
>
>
> It seems to be a major bug with the server. When do you fix this error? We paid today 500 Euros and are not able to work with the software!
>
Re: Very unsatisfied FoxTrot Search Server + Professional Search: client not connecting to the server [message #774 is a reply to message #772] Tue, 12 June 2018 09:21 Go to previous messageGo to next message
Andreas Freimüller
Messages: 2
Registered: June 2018
Junior Member
Am I assuming correctly that this is the same bug that I posted the other
day?
Re: Very unsatisfied FoxTrot Search Server + Professional Search: client not connecting to the server [message #777 is a reply to message #774] Tue, 12 June 2018 17:25 Go to previous message
Dirk Kannapinn
Messages: 2
Registered: June 2018
Junior Member
Version 6.5.1 Build 1870 seems to solve the problems: am able to connect to
the search server and am getting search results.

On Tuesday, June 12, 2018 at 9:21:17 AM UTC+2, Andreas Freimüller wrote:
>
> Am I assuming correctly that this is the same bug that I posted the other
> day?
>
Previous Topic: bug
Next Topic: How to exclude files by type (extension) from indexed folder
Goto Forum:
  


Current Time: Sat Apr 13 02:25:44 GMT+2 2024