FoxTrot Search Forum
FoxTrot Search for macOS Forum

Home » Public Forums » FoxTrot Search User Forum » Problem with search—No index selected
Problem with search—No index selected [message #1332] Sat, 15 January 2022 22:28 Go to next message
AJKS
Messages: 22
Registered: June 2020
Junior Member
In my "Search sources" pane I have a lot of indexes and they all have the check-box ticked.
But if I collapse the list by clicking on the triangle/caret then I'm told there is no index selected: "You must select at least one index in which to search."

When I expand the list it works as it should.

Must be a bug?

Version 7.1.2 build 2723 (Intel 64-bit) on macOS Monterey 12.1

Re: Problem with search—No index selected [message #1333 is a reply to message #1332] Sun, 16 January 2022 23:48 Go to previous messageGo to next message
CTM info
Messages: 148
Registered: September 2009
Senior Member
Hello,

I did check this and if you click on the disclosure triangle, things expand and contract. If you click on the master checkbox for a given server, it is normal that all become enabled/disabled, this is a feature.

Kind regards,

jean michel/ctm qa
Re: Problem with search—No index selected [message #1334 is a reply to message #1333] Mon, 17 January 2022 22:48 Go to previous messageGo to next message
AJKS
Messages: 22
Registered: June 2020
Junior Member
Maybe I have misunderstood.
I am not turning on or off the checkboxes.
When expanded all checkboxes are on (Actually not all, but most of them).
When I collapse/contract the list, it acts like all the checkboxes are off.

OK, it works like you say when ALL the check boxes are on.
It works the way I say when one of the search database is switched off.
Try that and see what you get.

/index.php?t=getfile&id=33&private=0

[Updated on: Mon, 17 January 2022 22:52]

Report message to a moderator

Re: Problem with search—No index selected [message #1335 is a reply to message #1332] Tue, 18 January 2022 15:56 Go to previous messageGo to next message
CTM info
Messages: 148
Registered: September 2009
Senior Member
Hello again,

Congratulations and thank you - you've identified a little bug there. Noted for a future version (we've already wrapped up the next release).

Kind regards,

jean michel/ctm qa
Re: Problem with search—No index selected [message #1336 is a reply to message #1335] Tue, 18 January 2022 17:26 Go to previous messageGo to next message
AJKS
Messages: 22
Registered: June 2020
Junior Member
Happy to oblige—how many is that now? 2 or 3? Smile

Re: Problem with search—No index selected [message #1431 is a reply to message #1335] Fri, 06 May 2022 01:56 Go to previous messageGo to next message
AJKS
Messages: 22
Registered: June 2020
Junior Member
Just an update, this bug is still in version 7.5b3.

Thanks

Re: Problem with search—No index selected [message #1437 is a reply to message #1431] Tue, 10 May 2022 10:19 Go to previous message
FoxTrot Engineering
Messages: 325
Registered: April 2020
Senior Member
Unfortunately this fix missed the 7.5 release. It will however be part of the next release.
Thanks for the report


Jérôme - FoxTrot Engineering
Previous Topic: Apple Mail results not in query
Next Topic: How to match single wild character in Foxtrot Query?
Goto Forum:
  


Current Time: Mon Aug 08 00:43:08 CEST 2022