FoxTrot Search Forum
FoxTrot Search for macOS Forum

Home » Public Forums » FoxTrot Search User Forum » Incompatible versions? (What are incompatible versions that require a rebuild in 7.1.2+)
Incompatible versions? [message #1345] Wed, 09 February 2022 17:10 Go to next message
Kyle
Messages: 4
Registered: August 2021
Junior Member
In v7.1.2 of FoxTrot Search admin there was a bug fix stating the following. To which index versions are you referring that will need updating? I have multiple indices created with v6.x which cannot be updated because the files are no longer accessible but we still need to search them. Perhaps you're talking about much older versions.

Quote:
Indices created by incompatible versions of FoxTrot now explicitly require a rebuild instead of behaving incorrectly. For this reason, we recommend all users of FoxTrot 7.x update to the most current version.
Re: Incompatible versions? [message #1346 is a reply to message #1345] Thu, 10 February 2022 09:44 Go to previous message
FoxTrot Engineering
Messages: 325
Registered: April 2020
Senior Member
This release note was referring to a future version of FoxTrot (7.5). Trying to use FoxTrot 7.1.2 with an index created with version 7.5 will ask for a rebuild, but earlier releases would behave incorrectly.
You can search indices created by older releases, and you can update them as well. A rebuild may be necessary only to benefit from some new features.


Jérôme - FoxTrot Engineering
Previous Topic: Revoke client license
Next Topic: What do you get for paying for a license?
Goto Forum:
  


Current Time: Mon Aug 08 00:52:32 CEST 2022