FoxTrot Search Forum
FoxTrot Search for macOS Forum

Home » Public Forums » FoxTrot Search User Forum » Indexing Apple Email runs very slowly
Re: Indexing Apple Email runs very slowly [message #485 is a reply to message #477] Mon, 20 February 2017 22:40 Go to previous messageGo to previous message
Robert White
Messages: 6
Registered: February 2017
Junior Member
I have attached about 5 samples from Crawler. I deleted the old Mail index
and set up a new one with the predefined template. The samples were done
at the start, after 10,000 files were indexed, then 20,000 and so forth
with the last one after it had been running several hours. The whole
process bogged down shortly after 20,000 files appeared to have been
indexed (but if I try to find something using just that index I don't get a
result - so it does not appear Mail is even partially indexed.

I also checked for plug-ins. I only have Mail Act-On. I did note that
there were a bunch of inactive Mail Act-On related "bundles" in the
User/Library/Mail folder. I deleted these before I recreated the index but
it doesn't appear to have had any impact.

On Thursday, February 16, 2017 at 11:16:26 AM UTC-8, Robert White wrote:
>
> I set up an index for Apple Mail using the predefined location. I have it
> set to index content. It starts indexing OK (e.g. it moves along pretty
> quickly) but then it starts to run slower and slower and eventually appears
> to freeze. I let it run for two days and it still had not completed. I am
> not sure how many email messages there are - probably close to 100,000. I
> am not sure if there is something the User\Library\Mail folder that is
> hanging it up. Any advice? Thanks
>
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: highlighting proximity searches
Next Topic: [ANN] FoxTrot Search version 6 public beta available for testing and reporting
Goto Forum:
  


Current Time: Sun Feb 05 20:49:01 CET 2023